Electronic Circuits Forum

Electronic circuit & projects discussion forum for Electronic enthusiasts to share and discuss. Place to discuss about electronic circuits, projects and hobby stuff.


Dancing LED circuit

Discuss about electronic circuits here. Request help for circuits that you couldn't find anywhere else, how a circuit works etc. Discuss anything related to electronic circuits.

Moderator: pebe

Dancing LED circuit

Postby Steel Guitar Player » Mon Mar 26, 2012 3:07 pm

I have been attempting to build the "Dancing LEDs" circuit for my grandson using a
breadboard as a 'testing location' prior to building it in a permanent closure.
The circuit can be found on this site at:

http://www.electronic-circuits-diagrams ... kt10.shtml

I have yet to be able to get it to work. As information I substituted 2N4401 transistors for the
BC548 type since the characteristics are pretty much the same. Both are NPN types with specs
that are similar enough to be interchanged for the project. All other components used were
as specified in the circuit. I have disassembled and rebuilt it several times being very careful
to wire it exactly as it is shown, but have had no success in getting it to operate.

So, my question is: Has anyone else successfully built this project and if so, did you find
any errors in the circuit schematic?

Thanks in advance for any help.
Steel Guitar Player
 
Posts: 4
Joined: Mon Mar 26, 2012 2:48 pm

Re: Dancing LED circuit

Postby pebe » Mon Mar 26, 2012 4:20 pm

I'm not surprised you cannot get it to work, for there are several mistakes in the circuit.

1. T2 and T4 are shown with their collectors and emitters reversed. Their emitters should be wired to ground, as T1 and T3 are.

2. C1 is shown with the wrong polarity. It should be wired with its +ve end connected to R1. Similarly, C3 has the wrong polarity.

3. With those two faults put right, the two oscillators should run OK. But R1 feeds 3 LEDs in parallel. They probably have dissimilar forward voltage drops, so only the LED with the lowest forward voltage will light. If you want them all to light you should feed each of the 3 LEDs with its own R1. The same with the other 3 groups of LEDs.

Good luck.
pebe
 
Posts: 857
Joined: Tue Dec 09, 2003 11:12 pm
Location: Ellon, Scotland

Re: Dancing LED circuit

Postby Steel Guitar Player » Mon Mar 26, 2012 6:03 pm

I SINCERELY appreciate the fast reply AND the corrections. I had already figured out that in order for them all to light that EACH LED would require it's own separate resistor. I'll get back to you with the results as soon as I can get time to work on it again.
Steel Guitar Player
 
Posts: 4
Joined: Mon Mar 26, 2012 2:48 pm

Re: Dancing LED circuit

Postby Steel Guitar Player » Tue Mar 27, 2012 10:00 pm

Well, I rewired the circuit making the changes indicated and I still can't get it to oscillate. Removed all LEDs except one for each 'leg' of the circuit and wired each with it's own resistor. Changed the capacitors out to several different values as well as the 33K resistors. As a last resort I also changed out the 2N4401 transistors (just in case I'd fried them - which turned out NOT to be the case since they worked well in another similar circuit I already had built) Also tried reversing the polarity, which didn't work either. There was one other thing that I tried and that's where the emitters of the two transistors are connected together and show going to ground. I am under the impression that the 'ground' in this case is the negative side of the 6 volt power source, but when that connection is made all it does is to completely kill the circuit. With the ground removed and power connected, the individual LEDs will light but not oscillate. The 250K pots only have the effect of varying the amount of brightness from one LED to the other when rotated from one extreme to the other.

As information, I have re-drawn the schematic with the corrections. I would have posted this, but don't know the procedure to do so on this site.

David
Steel Guitar Player
 
Posts: 4
Joined: Mon Mar 26, 2012 2:48 pm

Re: Dancing LED circuit

Postby pebe » Wed Mar 28, 2012 5:51 pm

It's easy to add a drawing. Ideally, your drawing should be filed as a .GIF rather than as a .JPG because it will be clearer.

When you have written your reply, go to the bottom panel and click on 'Upload attachment'. You can then use 'Browse' to find the drawing on your hard disc. Then click on 'Add the file'.
pebe
 
Posts: 857
Joined: Tue Dec 09, 2003 11:12 pm
Location: Ellon, Scotland

Re: Dancing LED circuit

Postby Steel Guitar Player » Wed Mar 28, 2012 6:23 pm

OK, here's the schematic of how it's wired at the present time. It still refuses to oscillate. Note that the corrections/modifications mentioned earlier are included and I have included only ONE LED on each side. If I can get it to work, I'll go back and add the rest as they were shown on the original schematic.
Clipboard01.gif
Modified schematic
Clipboard01.gif (20.59 KiB) Viewed 3676 times
achment]
Steel Guitar Player
 
Posts: 4
Joined: Mon Mar 26, 2012 2:48 pm

Re: Dancing LED circuit

Postby pebe » Thu Mar 29, 2012 3:11 pm

I have redrawn your circuit with the caps connected to the correct points. The circuit is of an astable multivibrator and the collector of each transistor has to be cross-coupled to the other transistor’s base.

My initial quick check of the original circuit did not alert me to a couple of other faults. The original did not show properly the voltage that supplied the LEDs. It looked to me like 10V with the top of the lettering cut off. If it was, then 100ohms is far too low – it would drive the LEDs at about 80mA. The gain of each transistor is about 100, so it would have needed a base resistance for each transistor to give a drive of at least 800microamps to make the circuit work. That would mean a minimum of 7500ohms – not the 33k + 250K shown.

In my circuit I have allowed for 2 LEDs in series in each leg. They drop about 2 volts each leaving about 2volts dropped across the 100ohms. If you want more, wire them in series and add a couple of volts to the supply voltage for each LED added. If you just want one LED, then increase the 100ohms.

The LEDs will take about 20mA, so that means the maximum base resistance will need to be 30K to give a 20mA/100 base drive, so I have picked the values shown.

The values of the caps will need to be upwards of 100uF – depending on the flash rate you require.

That said, a flashing lights circuit using a couple of 555 timers would be far better, and could incorporate random flashing. Let me know if you would like a circuit.
Attachments
Random LEDs.GIF
Random LEDs.GIF (4.18 KiB) Viewed 3645 times
pebe
 
Posts: 857
Joined: Tue Dec 09, 2003 11:12 pm
Location: Ellon, Scotland


Return to Electronic Circuits Help



Who is online

Users browsing this forum: No registered users and 3 guests